Critical Auto Update Bug in 4.9.3 is now fixed, update!

Couple of hours after WordPress 4.9.3 was released yesterday, the WordPress development team followed it up with 4.9.4 to fix the bug with the auto-update process. The bug apparantly generates a fatal PHP error when WordPress attempts to update itself. So, everyone should update to the latest version as quickly as possible in order to avoid the issues with the next auto-update cron.

This error requires WordPress site owners and administrators to manually update to WordPress 4.9.4 by visiting your Dashboard and clicking the Update Now button on the Updates page. Of course, you can update the WordPress by uploading the files via FTP or by using WP-CLI.

Dion Hulse, WordPress lead developer, says managed hosts that apply updates automatically for their customers will be able to update sites as they normally do. This may explain why some users have reported that sites running 4.9.3 have automatically updated to 4.9.4 without issue.

The bug stems from an attempt to reduce the number of API calls made when the auto update cron job is run.

A postmortem will be published once the team determines how to prevent this mistake from happening in the future. “We don’t like bugs in WordPress any more than you do, and we’ll be taking steps to both increase automated coverage of our updates and improve tools to aid in the detection of similar bugs before they become an issue in the future.”

Davor Veselinovic

Being web developer for more than 15 years should tell you quit enough. I'm in love with WordPress for over a decade now and I have pretty neat and huge WordPress experience. I have created some free themes and plugins for WordPress and I do like to share my knowledge with others. :)

Add comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Meks WordPress Themes


NEWSLETTER

Your Header Sidebar area is currently empty. Hurry up and add some widgets.